[sf-lug] SF-LUG jit.si meeting of July 3, 2022

Ken Shaffer kenshaffer80 at gmail.com
Sat Jul 30 20:47:50 PDT 2022

About the new MSI I'd mentioned at the meeting -- My 2011 Lenovo was
showing its age, so I found a new machine, an open-box special from

Dual boot setup of Ubuntu 22.04 and Windows 10 on an MSI GP66 Leopard

On Windows, updated and installed some games, then figured out
how much to allocate to Ubuntu.  Decided 100GB for root, 16GB for swap,
and a 20GB FAT partition for some casper-rw files for persistent ISO boots.
The rest would be an ext4  data partition.
>From Windows, shrank the C: partition, checked for errors, turned off
the fast startup buried in the power options.  Took a chance and didn't
bother with any Windows ahci drivers (turned out, none needed).

Googled to figure out which keys are for UEFI settings (DEL) and boot
selection (F11)
Entered UEFI settings to turn off TPM and Secure boot because  Nvidia
proprietary drivers will be used.

Booted an Ubuntu 22.04, and somehow missed the normal startup screen, went to a
virtual terminal, and ran startx, now I had a second screen, but
ubuquity installer
did not start (visibly).  Was on the other screen.  Eventually found
the right screen,
then did my gdisk partitioning for a 20GB FAT, a 16GB swap, a 100GB
root, and the rest
a data partition.

Tried something new, selected a wireless access point, to see if the Nvidia
drivers would be downloaded.  Made a bad password entry, leaving an
excess window
on-screen, corrected that but something failed, and froze up.
Rebooted and skipped
the wireless part, Assigned the pre-made partitions to root, swap and
The install succeeded, booted ubuntu, editing in the "nomodeset"
kernel param for the
default nouveau driver. Tried to change the boot order with
efibootmgr, which failed.
>From the UEFI Settings, had to double click on the boot entry to
change its order.
Then with ubuntu first, grub came up without f11 intervention.

The Intel ax210 wireless worked, so updated and upgraded, then
installed the Nvidia drivers from
"Software and Updates/Additional Drivers".  Rebooted, and noticed
Wayland was offered
under the gear on the login screen (It wasn't available under Nvidia before).

Pretty smooth install, much easier than some other machines with
wireless problems.

More information about the sf-lug mailing list