[sf-lug] Need help "spelunking" VMware install/uninstall problem on Ubuntu 7.04 (Feisty)...

RBV GoodWriter2548 at earthlink.net
Sun Nov 25 13:23:39 PST 2007

Thanks to Kristian and Ernest for their replies, as follows.

> If you ever used dpkg to install a VMware package, then I would purge
> that package.  Note that I said "purge", not "remove".  Additionally,
> VMware Server is in Canonical's feisty-commercial repository, so there
> is nothing special to do other than add the repository to your apt
> config and install it.  I have done it possibly hundreds of times on
> Ubuntu, and it always worked...

I believe I've already tried this via (a) Synaptic's "completely remove" and
(b) finding vestigial VMware installation packages via "locate vmware" and
deleting them.  I say "believe" because whatever steps I've taken along
these lines aren't, figuratively speaking, shaking the problem loose...

I also received this from Ernest De Leon (edeleonjr at gmail.com):

> If you already ran the uninstall script and it didn't find anything,
> then do a 'whereis vmware' from the terminal.  If anything pops up, go
> and manually delete all of what is left.

Been there and done that.  In fact, I've done it to the extent that I've
learned that it's possible to over-do it -- the VMware installer won't run
to completion if it can't find certain paths and folders, so I've had to
manually recreate them.  Doing so eliminates install-time "path/folder not
found" errors but still doesn't resolve the top-level problem of being able
to get a clean installation...

For what it's worth, there are multiple posts on the Ubuntu forum that
resemble mine, and a couple of "me too" in the posts that I created on this
subject.  So there's some fiddly bit that's not quite as it should be.

So it seems that something is missing from the uninstall programs, and that
whatever that missing piece is it's confounding my "one step beyond routine"
attempts to locate and remove files, etc.

At this point I'm contemplating filing a bug with Ubuntu...(?)

Cheers and thanks 'gain,

>> I've got a VMware Server / Ubuntu 7.04 Feisty problem I can't sort out.
>> See this thread on the Ubuntu forums for more details:
>> http://ubuntuforums.org/showthread.php?t=623122
>> Per that thread, the short version is that neither script based nor
>> Synaptic VMware installers / uninstallers seem willing to do their
>> jobs.
>> - The vmware-uninstall.pl script from a directly downloaded VMware 
>> installation package can find nothing that needs to be uninstalled.
>> - The same program's vmware-install.pl script fails because "A previous
>>  installation of VMware software has been detected."
>> - Synaptic (Feisty) also reports a previous instance of VMware and
>> won't continue.
>> - If I use apt-get to force the install, Synaptic stays stuck in a
>> "should upgrade / won't upgrade" loop per the forum post cited above.
>> At this point I've tried, per various Ubuntu forum threads, locating
>> and deleting several VMware directories, and tried multiple strategies
>> for "tricking" the installation programs into doing what they're
>> supposed to.
>> I've also done a reasonable amount of Web research trying to sort this
>> out, but remain hopelessly stuck.
>> Any ideas that can be understood and performed by a mere *user*, albeit
>> a moderately technically competent one (i.e., me), will be greatly
>> appreciated.
>> Cheers & thanks, Riley SFO

More information about the sf-lug mailing list