[sf-lug] i586 ThinkPad CD-ROM problems

Blake Haggerty Blake.Haggerty at Sapphire.com
Mon Nov 12 14:35:28 PST 2007

I was running into this same problem with a puppy Linux Install on a friends older Sony Vaio Laptop. The CD Rom would constantly fail on install/sometimes wouldn't work at all. I tried booting puppy Linux off of the USB stick  and when Puppy was up and running I could read off the CD no problem to an extent; until I had it doing something rather labor intensive and then it too would fail again. 


This may not be the problem with yours but certainly was the problem with my friends. His DVD drive just could not reliably read Burnt DVDs/CDs. I made a copy of Back to the Future I was able to play the entire movie with the original disc. The Burnt copy only lasted 5-10min. Yet if I played the burnt copy on my desktop computer if worked flawlessly.  


These older drives just sometimes don't cut the mustard when it comes to burnt media.







Blake Haggerty
Technical Recruiter 

Work: 415-788-8488 x215
Fax: 415-788-2592

Email: blake.haggerty at sapphire.com

Sapphire Technologies

See who we know in common


-----Original Message-----
From:Alex Kleider a_kleider at yahoo.com 
To: "Linux userGroup" ;
Sent: Nov 12, 2007 02:22:15 PM
Subject: [sf-lug] i586 ThinkPad CD-ROM problems

Rick chided me (justifiably of course) for not providing more specifics 
re my problems installing Mandriva. I've done some more experimenting 
and am beginning to worry that the CD-Rom may be dying although there 
is also some evidence to the contrary. 
Currently I'm running DSL (Damn Small Linux) with out problems BUT 
would like to switch to a more conventional distro. I AM able using the 
i586 ThinkPad running DSL to mount and read a CD burned on another 
(ubuntu) computer. For example I read the README file on the Mandriva 
CD this way. Pretty good evidence I thought that the CD-ROM drive works 
When doing an install (I've tried both Debian and Mandriva with similar 
results) the process stalls. 

during Debian install: 
it proceeds as expected untill the "Detecting Hardware" part- 
it fails to find the CD Rom drive and offers to let me submit one on a 
"No common CD ROM drive was detected" 
with the following reports on the display of another (virtual) 

ide-cd: cmd 0x5a timed out 
hdc : lost interrupt 
hdc: ATAPI 24X CD ROM drive 128 k Cache 
Uniform CD-Rom driver Revisioin: 3.20 
hdc: lost interrupt 

Mandriva starts with a "Mandriva screen"; notifies that booting is 
beginning and then that Kernel is loading; and then goes to another 
Mandriva screen and just sits there indefinitely; 
Ctl-Alt- F2 ---> another terminal with messages similar to those seen 
during Debian's install attempts: 

hdc : lost interrupt #this appears many many times 
ide-cd : cmd 0x5a timed out 

*looking for media adaptors 
*PCI : device 1069 5229 ffff ffff is "ALi Corporatioin IM5229 IDE", 
driver is alim15x3 
*have to insmod alim15x3 
*warning: unable to get module filename for ide core 
ide-cd : cmd 0x28 timed out 
hdc: lost interrupt 
/sbin/init: error while loading shared library invalid ELF header 
Kernel panic - not syncing: Attempted to kill init! 

All of this makes me think that the CD-Rom is failing BUT if that is 
true why does it read a CD normally using DSL Linux? 

Perhaps there is enough information here for someone to immediately 
recognize the cause of the problem; if not, I'm ready to suggest to my 
friend who owns this computer to pitch it into the trash! (But I'd 
rather conquer the problem instead!) 

Thanks alex 

alex at kleider.net 

Never miss a thing. Make Yahoo your home page. 

sf-lug mailing list 
sf-lug at linuxmafia.com 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://linuxmafia.com/pipermail/sf-lug/attachments/20071112/5303990a/attachment.html>

More information about the sf-lug mailing list