[dvlug] Need for Technical Assistance - Errorproblem? connecting MYSQL to HTTP

harry strout harry-strout at comcast.net
Mon Jan 4 10:21:43 PST 2010

Hi Rick.

Thank you for your efforts.
I tried local host and that did not work.

Personally, I think that it's the error from SELinux that is killing

How do I solve that one?

In terms of telling the truth, we all tell the truth, I hope.
However, verifying the truth holds more weight than speaking the

Is there of any way of you, or someone else, logging into my machine
remotely so as to see, in detail, what the problem is? 

Thanks again.

-----Original Message-----
From: dvlug-bounces at linuxmafia.com
[mailto:dvlug-bounces at linuxmafia.com] On Behalf Of Rick Moen
Sent: Monday, January 04, 2010 12:43 AM
To: dvlug at linuxmafia.com
Subject: Re: [dvlug] Need for Technical Assistance - Errorproblem?
connecting MYSQL to HTTP

Quoting harry strout (harry-strout at comcast.net):

> I agree with you on every point that you made, especially about
> from Missouri:
> "Truth from someone else's mouth is a lie.  The same truth
> is the truth."
> Therefore, I have tried to prove every point that you have made.

Hi, Harry.  I doubt anyone was even thinking you were in any way
untruthful.  The concern is that people reporting technical problems
often, with utterly and completely honest intent, omit crucial facts
inadvertently give their interpretations rather than the relevant raw

(You didn't really think your honesty was being questioned?  That
be most unfortunate.)

In attempting to help people diagnose problems, I found that sometimes
the phrase "Pretend I'm from Missouri and show me" light-heartedly
the vital point across that _showing_ the problem rather than
it is a necessary first step.  (For example, a diagnostician hearing
phrase "[x] didn't work" will be frustrated, thinking "But what does
'didn't work' mean?  What specifically did you try?  What specifically
happened?  What specifically did you expect to happen that didn't?")

> Please review the details of the attached zipped file and see if you
> can make any sense of it.

Um, wow.  That's a lot of stuff.  Anyhow....

Quoting one of your selinux-alert files:

> SELinux is preventing the http daemon from connecting to network
port 3306
> Detailed Description:
> SELinux has denied the http daemon from connecting to 3306. An httpd
> script is trying to do a network connect to a remote port

So, that's one problem, right there:  CentOS's "targeted policy" for
SELinux is preventing Apache httpd from connecting to TCP port 3306
see note below about target host), 3306 being the MySQL daemon's
communication port.

The error message goes on to suggest a way to modify the policy to
port 3306 access, I notice.

Except, important:  I notice that you seem to be trying to open a
connection to "compconsupp.com".  Not a good choice.  You should be
trying to connect to localhost.  That might actually be your sole

Looks like you had the same problem with Adminer:  You were trying to
connect to "compconsupp.com".  Try localhost.  Please let us know if
that works.  I'll bet it will.

> Yes, I am trying to install and connect to aMember Pro on a test
> developmental computer whose computer name "should be"
> compconssupp.com.

I don't know what this sentence means.  (I can think of a half-dozen
things you _could_ be trying to say.)

Your Amember.setup.log.1-3-10 file shows that MySQL itself is just
so that's another question answered.

dvlug mailing list
dvlug at linuxmafia.com

More information about the dvlug mailing list