[conspire] error debugging

Rick Moen rick at linuxmafia.com
Fri Oct 5 17:33:32 PDT 2012

Quoting Tony Godshall (togo at of.net):

> ...
> >> What is clutter?
> >
> > I had no idea until sixty seconds ago, when I burrowed through gthumb's
> > build dependencies, deciding 'clutter' is not an easily searchable
> > software name on account of massive overloading (and, um, clutter),
> > stumbled upon related software name 'clutter-gtk', Web-searched that,
> > and so indirectly found the correct 'clutter' pages that way.  Here they
> > are:
> >
> > https://clutter-project.org/
> ...
> The first time I heard of clutter was when Intel selected
> if for moblin's UI.  I was at Ampro Computers at the time,
> and IIRC we released a BSP (board support package) with
> Debian and Python and and Moblin packages for our
> customers.


Ruben, getting back to you on your recent comment:

> Yeah - I read something to that effect, including recompiling dozens of
> applications and libraries from scratch.  This is more than a bug.  Its
> a complete screw up.

I could be wrong, but my guess is:  OpenSUSE has adopted a GNOME
implementation that pretty much requires and assumes that your hardware
has DRI/OpenGL capability and is supported by OpenSUSE's DRI software
plumbing for OpenGL.  (If I remember my X Window System tinkertoys
correctly, that used to be AIGLX, which was merged into X.org starting
with version 7.1.  Time flies, and that's now kinda primordial software

My point:  The error you got, if I understand correctly, said that
gthumb tried to draw an object and reached for a hardware acceleration 
primative using the clutter toolkit layer, which then choked because 
clutter asked X.org's Direct Rendering Interface layer to do some
OpenGL for it, and X.org was unable to comply.

This implies either that X.org isn't correctly configured to do
DRI/OpenGL stuff (but theoretically could be, if you fixed it, e.g., by
having X.org load a DRI driver that works for your video chipset, _or_ 
that your video hardware just can't do OpenGL at all.  Like, for
example, if it's a really old video card like a bunch of mine.

  Several Open Source DRI drivers have been written, including ones for
  ATI Mach64, ATI Rage128, ATI Radeon, 3dfx Voodoo3 through Voodoo5,
  Matrox G200 through G400, SiS 300-series, Intel i810 through i965, S3
  Savage, VIA UniChrome graphics chipsets, and nouveau for NVIDIA. Some
  graphics vendors have written closed-source DRI drivers, including
  NVIDIA, ATI, and Kyro.


So, the main thing:  _Instead_ of recompiling a bunch of GNOME stuff to
not attempt to use clutter, a much more reasonable solution is probably
either (1) fix your X.org DRI configuration, or (2) swich to video
hardware manufactured in this millennium.

To verify that DRI is working, run the glxgears gadget and make sure the
gears turn.

_Or_, caveman-style verification like this:

$ glxinfo | grep "OpenGL renderer string"

Make sure the grep returns something _other_ than 'Software Rasterizer', 
which means no hardware-level acceleration functions were found and so
X.org is trying (badly) to fake the next best thing via software.

My own hardware is unspeakably ancient to a degree I will not even 
attempt to justify, but I don't expect it to do 
Compiz/GNOME/whatever 3D stuff, so it gets by.

More information about the conspire mailing list