[sf-lug] jim unsatisfied with apt-get and adobe flash and other things

Asheesh Laroia asheesh at asheesh.org
Tue Nov 25 08:02:09 PST 2008

On Mon, 24 Nov 2008, jim wrote:

> * i'm in this because i'm trying to help an impoverished
> musician avoid spending $100 or more per hour for someone
> to edit a simple HTML file. to verify my work, i have to
> access her web site, which looks like it was done on
> windows with windows for windows. haven't dragged out a
> mac to see if that box sees things correctly. i abjectly
> got to a windows machine (old w98) and things worked.
> i'm completely new to multimedia and generally avoid it.

I'm glad to hear you at least got your problem solved so you can stress 
out about Flash and sources.list separately from stressing out about 
helping the musician!

> * i like CLI, but try sometimes to be a good boy and
> follow instructions, even GUI, when i'm asking for help
> (i like help from sf-lug people much better than from
> gui folks).


I'm a little less in a rush now; sorry, otherwise I would have been more 
verbose in the past!

>   i don't use synaptic or upgrade whatever or much else
> from the GUI system menu, this being an exceptional case.

Me, neither, though I like to try them out from time to time so that if I 
want to help people who prefer the GUI stuff, I'm not totally lost.

> * examples help loads. the so-called "arguments:" now look
> like path specifications to me.
>   in the file:
> deb http://linux.csua.berkeley.edu/ubuntu/ hardy main multiverse restricted universe

I think of the last n columns after "hardy" (the distribution 
specifier) kind of like the shell's globbing:

deb + http://linux.csua.berkeley.edu/ubuntu/ + 
hardy + {main,multiverse,restricted,universe}

>   on the target system:
> http://linux.csua.berkeley.edu/ubuntu/dists/hardy/main/binary-i386/Packages.gz
> http://linux.csua.berkeley.edu/ubuntu/dists/hardy/multiverse/binary-i386/Packages.gz
> http://linux.csua.berkeley.edu/ubuntu/dists/hardy/restricted/binary-i386/Packages.gz
> http://linux.csua.berkeley.edu/ubuntu/dists/hardy/universe/binary-i386/Packages.gz


>   the manpage-like syntax now seems to look like:
> (deb | deb-src) URI Release_subdirectory [branch_subdirectories...]
> -------------------------------
> * yes, it was a last resort effort, done with tears in eyes.

There are tears in my eyes, too, but actually that's because I'm allergic 
to cats.

Regarding the original issues:

re: "Size Mismatch":

I'm actually still somewhat astonished that an official US Ubuntu mirror 
was so broken.  Perhaps it was your connection to it?  I wonder if it 
still has those issues.

I personally like using the Berkeley one since it's fast in SF.

re: Desire to install Flash 10

The best advice to give you here is, "Upgrade to Ubuntu 8.10, and then 
install the flashplugin-nonfree package."  Flash 10 could possibly depend 
(by "depend" here I don't mean "has a package that claims to depend," I 
mean "actually won't work without") some newer stuff than what ships in 
7.04.  It's possible it doesn't, and we can try things out.

Is there a reason you prefer Ubuntu 7.04 to 8.10?

-- Asheesh.

Good day for overcoming obstacles.  Try a steeplechase.

More information about the sf-lug mailing list