[sf-lug] Puppy Linux

Blake Haggerty Blake.Haggerty at Sapphire.com
Thu Oct 11 18:10:42 PDT 2007

Does anyone have experience with Puppy Linux?


I have been trying to get Linux installed on a friends computer but it has been one headache after another (probably due to my lack of experience). Of course when I do an install on my own computer everything works great but when I work on someone elses, I botch the job. 


So my original choice of Linux install was xunbuntu, but that got thrown out because his DVD drive took a crap and now refuses to read anything or at least will only read a disk once every 30 trys and it only reads the disk for 5 min. or so until it decides to make awfull noies and  stop.


So I researched some other distributions that I could install with a USB pen drive. I found puppy Linux. His computers Bios does not offer the option to boot from the USB so I had to use a piece of software called Wakepup on a floppy disk that is essentially a version of freedos that searches USBports flash drives CDrom and harddrive for Puppy Linux and then boots it off that device.  


So after copying puppy Linux onto the pendrive and using wakepup to boot I can get Puppy up and running and get to the gui. My goal is to install it completely to the harddrive so that I do not need to use  wakepup or the pendrive. 


So first thing I did was partition th 60gig hard drive like so


Primary partition #1  Tagged as boot,          formatted as Linux ext2                  5gigs (This is where I installed puppy)

                         #2                                   Formatted as Linux ext2                 54.2gigs

                         #3                                   Formatted as Linux/Swap               800Megs  (double the ram I'm told)  


So once I have everything partitioned and formatted I then  run the puppy universal installer. Once i go through the steps I install Puppy onto partition #1. It then asks if I want to install Grub. I say yes and it goes through  the steps of installing grub to the partition. It says grub has finished installing.


Then I shutdown the computer and remove the pendrive and floppy of wakepup and start it back up. The computer goes through the typical Bios and mem checks etc. and then 1 of two things happens either  A.It says "Operating System Not Found" OR B. It just goes to a blank screen with a cursor blinking in the top left corner. I have had both  things happen after trying to reboot a few times.


I have tried many different partitioning Schemeas and am about ready to pull my hair out. I figure it has something to do with the configuration of Grub but I really dont even know where to begin on how to fix that. I have done endless Google searches and still no help.  Does anyone have any suggestions on how to get puppy to boot straight off the hard drive?


I am on the edge of just putting  XP back on it and telling him sorry cant do it. But I have got him excited so I dont want to let him down.


I am willing to meet up with someone if you would like to tinker with the Laptop. 

Blake Haggerty
Technical Recruiter 

Work: 415-788-8488 x215
Fax: 415-788-2592

Email: blake.haggerty at sapphire.com

Sapphire Technologies

See who we know in common

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://linuxmafia.com/pipermail/sf-lug/attachments/20071011/605d0ca1/attachment.html>

More information about the sf-lug mailing list