[sf-lug] Segfaulting

Nathan nathank at evilmonkeys.com
Fri Oct 27 11:39:14 PDT 2006

When I run xmms, mplayer, or amarok they will all segfault right way.
Re-installed all the packages and still the same result. First I though
I may have something to do w/ alsa but I can still get sound though the
flash plugin in firefox and mpg123 works fine. For fun I installed a
newer kernel and re-installed alsa, neither worked.

Never really used gdb for anything so I guessed now would be a good time
to start, ran it and got this:

(gdb) run
Starting program: /usr/bin/xmms
Failed to read a valid object file image from memory.
[Thread debugging using libthread_db enabled]
[New Thread 16384 (LWP 11896)]
[New Thread 32769 (LWP 11899)]
[New Thread 16386 (LWP 11900)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 16384 (LWP 11896)]
0xb7f0894e in _dl_rtld_di_serinfo () from /lib/ld-linux.so.2
(gdb) bt
#0  0xb7f0894e in _dl_rtld_di_serinfo () from /lib/ld-linux.so.2
#1  0xb7b926d5 in _dl_open () from /lib/libc.so.6
#2  0xb7f0b43f in _dl_rtld_di_serinfo () from /lib/ld-linux.so.2
#3  0xb7b91e0f in _dl_open () from /lib/libc.so.6
#4  0xb7cc3d8e in dlopen () from /lib/libdl.so.2
#5  0xb7f0b43f in _dl_rtld_di_serinfo () from /lib/ld-linux.so.2
#6  0xb7cc41bd in dlvsym () from /lib/libdl.so.2
#7  0xb7cc3d21 in dlopen () from /lib/libdl.so.2
#8  0x0806843d in add_plugin ()
#9  0x080686b8 in scan_plugins ()
#10 0x08068a2b in init_plugins ()
#11 0x0808b38e in main ()

Since I'm not much of a coder and this will be the 3rd time I've ever
used gdb. I cant really tell what is going on. Ran it for mplayer also
but it's got even less info. Anyone have clues about what is going on?
mpg123 is no civilized way to listen to music ;)


More information about the sf-lug mailing list