[conspire] missing rDNS for (intentionally missing) IPv6
Tim Utschig
tim at tetro.net
Thu Mar 4 16:28:54 PST 2021
On Wed, Mar 03, 2021 at 01:41:28PM -0800, Rick Moen wrote:
> what guarantee is there that it would be the same IPv6 address if the
> server got one again? Or, to reframe the question, how do I make sure
> the autoconfigured IPv6 assignment is deterministic?
I don't know how Comcast does IPv6 these days, but with AT&T I
had a look at the web UI on my Uverse router and noticed an IP
address for a 6RD server*.
* I would be very surprised if this was actually implemented
with traditional "servers" and not just a part of their
router configs - it's certainly been reliable and low-latency
enough to probably be a core feature of their network.
Knowing a teeny bit about 6RD I thought, "Hmm, I wonder if I can
just plug in one of my AT&T-assigned static IPv4 address and have
a static /60..." Sure enough, it worked perfectly and still does
~5 years later.
I intend to (someday) investigate whether static *native* IPv6 is
something AT&T offers these days. I'm pretty sure they have
native *dynamically-assigned* IPv6 addressing, but that's not
what I want.
Some details of my config (OpenWRT) are below in case it helps:
# /etc/config/network
config interface 'lan'
option ifname 'eth0.1'
option type 'bridge'
option proto 'static'
option ipaddr '<internal_ip_of_my_router>'
option netmask '255.255.255.0'
list dns '8.8.8.8'
list dns '8.8.4.4'
list dns '2001:4860:4860::8888'
list dns '2001:4860:4860::8844'
option ip6assign 60
config interface 'wan'
option ifname 'eth0.2'
option proto 'static'
list ipaddr '107.209.154.41'
list ipaddr '107.209.154.42'
list ipaddr '107.209.154.43'
list ipaddr '107.209.154.44'
list ipaddr '107.209.154.45'
# AT&T 6rd prefix + 107.209.154.41
list ip6addr '2602:306:bd19:a290::1/60'
option netmask '255.255.255.0'
option gateway '107.209.154.46'
list dns '8.8.8.8'
list dns '8.8.4.4'
list dns '2001:4860:4860::8888'
list dns '2001:4860:4860::8844'
option ipv6 1
option defaultroute 1
config interface 'wan6'
option proto '6rd'
option ifname '6rd'
option peeraddr '12.83.49.81'
option ipaddr '107.209.154.41'
option ip6prefix '2602:300::'
option ip6prefixlen '28'
option ip4prefixlen '0'
# /etc/config/dhcp
config dhcp 'lan'
option interface 'lan'
option start '150'
option limit '200'
option leasetime '12h'
# Not sure why I didn't use "list dns" for these as well.
option dhcp_option '6,8.8.8.8,8.8.4.4'
option dhcpv6 'server'
option ra 'server'
option ra_maxinterval 1800
list dns '2001:4860:4860::8888'
list dns '2001:4860:4860::8844'
I think that might be all relevant bits. Good luck!
(Ignore the ".1" and ".2" I set up VLANs for fun at some point).
--
Tim Utschig <tim at tetro.net>
More information about the conspire
mailing list