[conspire] kernel crash reported // for wifi ?

Rick Moen rick at linuxmafia.com
Mon Jun 4 17:52:03 PDT 2012

Quoting Ken Bernard (kenbernard at gmail.com):

> Hi everyone -
> I get an annoying message when ever I use Wifi on my* Centos 6, Lenovo
> ThinkPad (T61*). I think I asked about this earlier this year, or late in
> 2010. Laptop uses Gnome, but can dual boot to Windows XP.
> I got my Wifi to work, but I am sure that I did many things that Daniel G.
> would not do. I got it to work by adding libraries and checking the
> internet forums.
> This is what I get besides the black box that says: Kernel Crash has
> occurred.:
> Crash Kernel Report -- to do with wireless drivers (I downloaded and
> installed drivers to get wifi to work on installation)
Hi, Ken.  

I've delayed a few days in getting back to you on that, in part because
you posted so much detail that it's a bit of a challenge to assess it.
I notice:

> I tried many times and many ways to get MADwifi working
> I tried to install ath5k also
> I know I took a shotgun approach to getting wireless working

I don't want to seem critical of anyone taking a shotgun approach to
solving a technical problem.  Heavens knows, I do it often enough.  I
just wanted to point out that there's a severe drawback:  You introduce
new variables.

The most commonly successful general approach to diagnosis is:
_eliminate_ variables.  That entails changing only one thing at a time,
and carefully putting it back (real, genuine, we're-not-kidding back)
before attempting something different.  Otherwise, you may break
something new or introduce unplanned interactions, taking you further
from an answer rather than closer.

For example:  madwifi, which is an open-source driver that is a wrapper
into which you insert a proprietary 'HAL' (Hardware Abstraction Layer) 
binary firmware piece.  You've attempted that driver, and you've also
attempted the newer ath5k driver for Atheros chips that is intended to
take the place of madwifi and no longer requires the binary HAL piece.
The problem is, your system _might_ be in a messed up state.

You might find it easiest to just retry loading CentOS 6.  (FYI, CentOS
6.2 has been out for quite a while and is actually preferable.)

> reason: WARNING: at drivers/net/wireless/ath/ath5k/base.c:1142
> ath5k_tasklet_rx+0x4ab/0x590 [ath5k]() (Tainted: G        W

Now, that's very curious.  'Tainted'.  But I suspect that message is not
on account of ath5k but rather some proprietary driver that's for some
reason still in kernelspace.  If you are unsure what driver that is, you
might want to check 'lsmod' output to spot it, because it could be
causing trouble.

>         file is cut and paste from <
> http://madwifi-project.org/wiki/UserDocs/UsersGuideExamples >
>                 Scroll downb to: "Single AP with hostapd on an
> Automatically Chosen Channel"

'AP' is Access Point.  Are you _sure_ you want to set this machine's
Atheros-based wireless interface up as a Wireless Access Point?  More
commonly, you would want to configure it as a station.

I think you're barking up the wrong tree, in attempting to find a canned
recipe on a Web page like
http://madwifi-project.org/wiki/UserDocs/UsersGuideExamples . All of
those examples look overengineered, to me.

Remember my explanation to chaz at chazbrenchley.co.uk a couple of weeks
ago, the guy who had the Ralink-based wireless card from Dell?  I would
suggest you want to proceed the way I described in his case

sudo modprobe -v [name of driver]

When you are able to do those two commands and have a wireless interface
show up in the iwconfig output (when it was not before), then you will
have broken the back of the problem.

Maybe if you just install CentOS 6.2 (with the wireless card present),
the whole matter will resolve itself.  That certainly will implicitly 
solve the problem of any mess-uppedness you might have introduced to
your system -- and without the need to download drivers.

More information about the conspire mailing list