[conspire] kernel crash reported // for wifi ?

Ken Bernard kenbernard at gmail.com
Sat Jun 2 10:12:17 PDT 2012

Hi everyone -
I get an annoying message when ever I use Wifi on my* Centos 6, Lenovo
ThinkPad (T61*). I think I asked about this earlier this year, or late in
2010. Laptop uses Gnome, but can dual boot to Windows XP.

I got my Wifi to work, but I am sure that I did many things that Daniel G.
would not do. I got it to work by adding libraries and checking the
internet forums.

This is what I get besides the black box that says: Kernel Crash has

Crash Kernel Report -- to do with wireless drivers (I downloaded and
installed drivers to get wifi to work on installation)

Package:        kernel
Latest Crash:    Thu 13 Oct 2011 03:05:16 PM
Command:        not_applicable
Reason:         WARNING: at drivers/net/wireless/ath/ath5k/base.c:1142
ath5k_tasklet_rx+0x4ab/0x590 [ath5k]() (Tainted: G        W
---------------- )
Bug Reports:    The report was appended to /var/log/abrt.log
The Bug Report /var/log/abrt.log  10-13-2011 15:05

[kbernard at centos6-thinkpad-t61 ~]$ sudo cat /var/log/abrt.log | less
[kbernard at centos6-thinkpad-t61 ~]$ sudo cat /var/log/abrt.log
architecture: i686
cmdline: not_applicable
component: kernel
executable: kernel
kernel: 2.6.32-71.29.1.el6.centos.plus.i686
package: kernel
reason: WARNING: at drivers/net/wireless/ath/ath5k/base.c:1142
ath5k_tasklet_rx+0x4ab/0x590 [ath5k]() (Tainted: G        W
---------------- )
release: CentOS Linux release 6.0 (Final)
time: 1314148422
uid: 0

WARNING: at drivers/net/wireless/ath/ath5k/base.c:1142
ath5k_tasklet_rx+0x4ab/0x590 [ath5k]() (Tainted: G        W
---------------- )
Hardware name: 7658CTO
invalid hw_rix: 1b
Modules linked in: fuse autofs4 sunrpc cpufreq_ondemand acpi_cpufreq
ipt_REJECT nf_conntrack_ipv4 nf_defrag_ipv4 iptable_filter ip_tables
ip6t_REJECT nf_conntrack_ipv6 xt_state nf_conntrack ip6table_filter
ip6_tables ipv6 dm_mirror dm_region_hash dm_log uinput thinkpad_acpi hwmon
wmi sg i2c_i801 iTCO_wdt iTCO_vendor_support arc4 ecb ath5k mac80211 ath
cfg80211 rfkill snd_hda_codec_analog snd_hda_intel snd_hda_codec snd_hwdep
snd_seq snd_seq_device snd_pcm snd_timer snd soundcore snd_page_alloc
e1000e ext4 mbcache jbd2 sd_mod crc_t10dif sr_mod cdrom firewire_ohci
firewire_core crc_itu_t yenta_socket rsrc_nonstatic ahci pata_acpi
ata_generic ata_piix i915 drm_kms_helper drm i2c_algo_bit i2c_core video
output dm_mod [last unloaded: microcode]
Pid: 0, comm: swapper Tainted: G        W  ----------------
2.6.32-71.29.1.el6.centos.plus.i686 #1
Call Trace:
[<c0450201>] ? warn_slowpath_common+0x81/0xc0
[<f959383b>] ? ath5k_tasklet_rx+0x4ab/0x590 [ath5k]
[<f959383b>] ? ath5k_tasklet_rx+0x4ab/0x590 [ath5k]
[<c04502d3>] ? warn_slowpath_fmt+0x33/0x40
[<f959383b>] ? ath5k_tasklet_rx+0x4ab/0x590 [ath5k]
[<c045627e>] ? tasklet_action+0x9e/0xb0
[<c045726f>] ? __do_softirq+0x8f/0x1b0
[<c0427dcf>] ? ack_apic_level+0x5f/0x1f0
[<c04af7cf>] ? handle_fasteoi_irq+0x7f/0xd0
[<c04573cd>] ? do_softirq+0x3d/0x50
[<c0457525>] ? irq_exit+0x65/0x70
[<c040b7d0>] ? do_IRQ+0x50/0xc0
[<c040f828>] ? sched_clock+0x8/0x10
[<c040a0f0>] ? common_interrupt+0x30/0x38
[<c065420a>] ? acpi_idle_enter_bm+0x25e/0x28f
[<c0740b22>] ? cpuidle_idle_call+0x72/0xf0
[<c0408884>] ? cpu_idle+0x94/0xd0
[<c0a409af>] ? start_kernel+0x39f/0x3a4
[<c0a4044e>] ? unknown_bootoption+0x0/0x190

I tried many times and many ways to get MADwifi working
I tried to install ath5k also

I know I took a shotgun approach to getting wireless working

I created a file "/etc/hostapd.conf"
        file is cut and paste from <
http://madwifi-project.org/wiki/UserDocs/UsersGuideExamples >
                Scroll downb to: "Single AP with hostapd on an
Automatically Chosen Channel"

       I tried to run the " myprompt# wlanconfig ath create wlandev wifi0
wlanmode ap
        ath0 "  command but got error unrecognised

Wifii worked after reboot but with this Bug reported
this Bug report occurs from time to time when I use wifi (beyond first
time, most times I use wifi I get the Kernel Crash report, but not every
time I use a Wifi connection)

1. First time I was able to use wifi card -- but I also got this message
about kernel module crash
2. Was able to connect to internet with wireless-- even though I got this
3. Restart wireless after reboot??? should reproduce the crash message it,
does sometimes usually within 15 minutes, but I haven't deliberately tried
to reproduce this Bug.

should I just continue ignoring this message?
Ken Bernard

P.S. I am always planning to drop Rick's on CABAL Saturdays but I always
seem to  be too busy.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://linuxmafia.com/pipermail/conspire/attachments/20120602/b6795491/attachment.html>

More information about the conspire mailing list