[conspire] efilinux

Rick Moen rick at linuxmafia.com
Mon Jul 2 20:43:03 PDT 2012

I wrote:

> I don't have all the details handy, but Canonical, Ltd.'s decision to
> use the efilinux bootloader + shim rather than GRUB2 + shim or elilo is
> that it's BSD licensed rather than GPL.  GRUB is GPLv3, and Canonical
> fears that users would exercise their right to be given necessary
> 'authorisation keys' under GPLv3 section 6, and that Microsoft would
> respond by revoking Canonical's certificate.

Of course, they could use elilo (which is GPLv2) with no such potential
drawbacks -- but that's not shiny, fashionable, and overengineered.  ;->

More information about the conspire mailing list