[conspire] Ubuntu 9.04

Rick Moen rick at linuxmafia.com
Sun Oct 9 21:53:53 PDT 2011

Quoting =JeffH (Jeff.Hodges at KingsMountain.com):

> (there were some stories of issues with the auto LTS->LTS upgrade the
> last time). 

Ah, you mean the severely and completely broken 8.04 LTS Hardy Heron to
10.04.1 LTS Lucid Lynx upgrade path that I encountered this past March,
almost a year after Lucid Lynx had been released?
I was severely underwhelmed by that, and thought it a pretty appalling
failure.  Almost a year to fix invalid file descriptors in a single
Ubuntu package (tar) that made their supposedly _safest_ upgrade path
not work on kernel revisions below 2.6.22, and they couldn't bother to
fix it?  Wow, that's a pretty ppor showing.[1]

> And yes, one can migrate over to some other desktop UI regime, eg
> XFCE. I've not done that (yet) because I'm sitting tight on a
> gnome+kde mix that's working for me. when i next upgrade to a new
> LTS,  I may be at that time driven to look at other desktop UI
> regimes.

Don't forget about just not bothering with a 'Desktop Environment' at
all, and just using your choice of window manager.  See:
http://xwinman.org/  for screenshots and links.

I keep hearing people claiming to be afraid of upgrading to even
modestly leading-edge distro versions because they once tried it and
part of KDE broke, or part of GNOME broke, and my first thought keeps
being:  Hey, maybe your best solution is to not tie yourself to a whole
desktop suite inclined towards dependency hell?

Since you say you already use part of GNOME and part of KDE, you're
already using an 'a la carte' approach where indivudual applications are
concerned, so maybe you should consider doing it for desktop frameworks
as well, i.e., 'sudo mv /etc/alternatives/x-session-manager ~', install
the window manager of your choice, use 'sudo update-alternatives
--config x-window-manager' to set it as default, and reboot.

[1] Admittedly, the linked example is a slightly special case in that
Linode virthosts may only run specially compiled kernels provided by
Linode, and I didn't upgrade that kernel to '2.6.38-linode31' until
later.  Many Xen users and users of Linux Containers have similar kernel
constraints.  However, I'd at least expect Ubuntu's upgrade tools to
halt and say 'WARNING:  Because you are running a pre-2.6.22 Linux
kernel and a pre-blah-blah version of GNU tar, this upgrade will break
if you continue.  See page [foo] for workarounds.'

More information about the conspire mailing list