[conspire] Multiple versions of avahi ???
rick at linuxmafia.com
Fri Jun 13 12:25:07 PDT 2008
Quoting David Fox (dfox94085 at gmail.com):
[Ken's package saying it needs a -devel dependency:]
> That is bizarre. On Ubuntu HH 64 I have this:
> dfox at newbox:~/The Outer Limits/Season 2 - Complete$ aptitude show hplip
> Package: hplip
> State: installed
> Automatically installed: yes
> Version: 2.8.2-0ubuntu8
> Priority: optional
> Section: utils
> Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss at lists.ubuntu.com>
> Uncompressed Size: 791k
> Depends: adduser (>= 3.34), coreutils (>= 5.1.0), cupsys (>= 1.1.20),
> hplip-data (> 2.8.2), hplip-data (< 184.108.40.206), libc6 (>= 2.4),
> libcupsys2 (>= 1.3.4), libjpeg62, libsane (>= 1.0.11-3),
> libsnmp15 (>= 5.4.1~dfsg), libssl0.9.8 (>= 0.9.8f-1), libusb-0.1-4 (>=
> 2:0.1.12), lsb-base (>= 3), python (>= 2.5), python (< 2.6),
> python-imaging, python-support (>= 0.7.1)
> No -devel dependencies there.
I'm speculating that Ken might have gotten shot in the foot by listing
incompatible third-party RPM repositories in his repos list. You can
get into some strange and untenable dependency situations, that way.
Ken might want to just "rpm -e" (erase/remove) a bunch of the packages
that are implicated in this mess, in particular any and all that he's
recently pulled down from whatever that third-party repository is, and
then replace that software from more-conventional Fedora 9 and closely
compatible package sources.
I believe the Livna repo is still considered closely compatible, for
(Disclaimer: My understanding of Fedora might very well be outdated.)
More information about the conspire