[conspire] wedged Debian Sid

Bill Moseley moseley at hank.org
Tue Oct 2 13:56:40 PDT 2007

After a few years following Sid I've finally got a problem on one of
my machines.

Trying to run an update it says I need to install glibc which then

    Do you want to upgrade glibc now? [Y/n] 

    WARNING: POSIX threads library NPTL requires kernel version
    2.6.8 or later. If you use a kernel 2.4, please upgrade it
    before installing glibc.

Then trying to install 

$ sudo apt-get install -t etch linux-image-2.6.22-2-k7
Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  kernel-patch-xfs: Depends: grep-dctrl
  libc6-dev: Depends: libc6 (= 2.6.1-5) but 2.5-9+b1 is to be installed
  linux-image-2.6.22-2-k7: Depends: initramfs-tools (>= 0.55) but it is not going to be installed or
                                    yaird (>= 0.0.12-8) but it is not going to be installed or
  locales: Depends: glibc-2.6-1
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I asked on debian-user and someone suggested:

- boot a Debian(-based) live/rescue CD with a new enough kernel
- chroot into your normal installation
- update libc6 et al.
- install the new kernel image
- verify that grub knows about the new kernel
- reboot your system with the new kernel image

This seem sane, or is there anything else someone could recommend?

$ uname -a
Linux bumby 2.6.6-xfs-athlon #1 Thu Jul 22 15:22:53 PDT 2004 i686 GNU/Linux

It's an Athlon XP 1800+ with xfs file system.  I think I had to patch
in xfs last time I build the kernel (whichlooks like, eh, about 2004).

Bill Moseley
moseley at hank.org

More information about the conspire mailing list