[conspire] Breezy/kppp/Netzero

Daniel Gimpelevich daniel at gimpelevich.san-francisco.ca.us
Thu Dec 29 00:07:28 PST 2005

On Wed, 28 Dec 2005 18:23:16 -0800, John Andrews wrote:

> Daniel
>     I appreciated your analysis of Netzero.deb. I've looked at dozens of
> articles and not many have come up with a way to run it on linux. I'm about
> to give up on it and try one which is linux friendly called highstream.com.

That's always your option, but if you're having problems dealing with
connect issues on one ISP in a Linuxy manner, you're going to have similar
problems dealing with any connect issues that may arise on another ISP,
and I'm not referring to technical problems. In the message immediately
prior to my "Analysis" message, I broke a diagnostic workflow down into
steps, and asked you to report the results of each step. Either I am
having severe trouble recognizing your report back as being the results of
those steps, or you just did your own thing, which may or may not be
equally helpful to me in helping you, as I shall attempt to make sense out
of it below in the context of what you're trying to accomplish.
Furthermore, let it be known that I wanted to see for myself how quickly I
could connect to NetZero under Linux myself, so I booted the Knoppix 4.0.2
CD a few minutes ago, downloaded and installed the NetZero client, and
made sure it would be my only net-connection by turning off Ethernet with:

sudo ifconfig eth0 down

I created the /dev/modem symlink and then started the NetZero client with:

sudo -b /opt/nzclient/runclient.sh

I told it to create a new account, and it successfully dialed the modem
and connected. It told me to wait for the sign-up window to appear, and
Firefox opened a blank window (I already had Konqueror running) and
complained that it wasn't able to reach the URL, without telling me what
the URL was. I told Firefox to go to www.netzero.com, and it instantly
redirected me to www.netzero.net and successfully displayed that page at
dial-up speed. I then tried a non-NetZero URL, and their proxy kicked in,
telling me that I need to be logged in to a NetZero account in order to do
that. So, presumably, I could then use the NetZero website to create an
account while connected to NetZero, and then go back to the other window
that was still waiting for sign-up information, put the new account
information in there, and be off!

>     I'm trying to establish that my kppp works right. When you are

By "works right" I understand you to mean: dials, connects to remote
modem, fails to establish PPP link.

> configuiring it and query the modem while you are in the configuation mode
> it responds properly. Even if you switch /dev/modem and /dev/ttyS0 between
> two boxes you still get a positive response.However when you start it from a

I'm not sure what you mean by switching them "between two boxes" here. Are
you switching between two computers? Are you switching the modem
connection on the back of the computer? What I asked you to do was switch
kppp's connection between /dev/ttyS0 and /dev/modem and see whether it
behaves identically with each, to test the usability of the /dev/modem
symlink, and nothing more.

> terminal and then hit the connect button you get this result and kppp
> freezes up.Do you have any ideas as to what is causing it to freeze up?

I did not ask you to start kppp from the terminal, but I did ask whether
it asks for a password at any time when you start it from the K menu
(sorry if I wasn't specific enough). If it asks for a password, it is
doing so in order to become root. If it normally needs to be root, but you
start it without root privileges by, for example, typing only "kppp" in
the terminal, don't expect it to work properly. On the other hand, if kppp
never asks for a password when started from the K menu, I have no idea
what is causing it to freeze up.

>     jla at vstrom  $ kppp    The kppp starts properly at this point. Then when
> you try to connect it does this .
> opener:    received setsecret
> opener:    received setsecret
> opener:    received openlock
> opener:     received opendevice

Yeah, those are largely irrelevant-to-the-ultimate-goal internal kppp
messages. If kppp is able to dial when started from the K menu and told to
use /dev/modem, the symlink works, and you don't need to have anything
more to do with kppp. On to the NetZero client. Is it now able to dial and
attempt to connect? If not, tell me _exactly_ what it says in the little
window that tells you something is wrong. If, on the other hand, it
successfully dials and then flakes out while trying to establish a
SUCCESS. Do not interpret failure to establish a connection at this
particular point in the process as a bad thing, because it is known that
the NetZero client cannot function properly without root privileges, and
you have not given it those yet, and should not until everything else is
verified to be as it should be. When you get to that stage, the way I
would recommend for specifically you to accomplish that would be to
right-click on the NetZero icon on your desktop, select Properties, click
on the Application tab, and edit the Command field to begin with "gksudo "
so that it says "gksudo /opt/whatever" there, and click OK. Note that
gksudo is part of Ubuntu, not Kubuntu, but you have them both installed in
a combined system, and I would consider gksudo to be a more
straightforward option in such a case than either kdesu or the Advanced
Options button in that Application tab, which also allows running as a
different user, such as root.

More information about the conspire mailing list