[conspire] Broadcom NetExtreme BCM5705 ethernet driver, Help!
rick at linuxmafia.com
Sun Feb 29 19:43:57 PST 2004
Quoting Bill Stoye (skiffworks at earthlink.net):
> I did try to install kernel 2.6.2-2, from Debian's unstable branch,
> failed miserably and went back and did a fresh Libranet installation.
Hmm, that's a shame. (However, see near bottom.)
As a suggestion, any time you're experimenting with new kernels, take
care not to burn your bridges with the existing, known-good kernel you
already have in place. E.g., if you're using lilo (as opposed to GRUB,
the most popular boot loader these days), make sure you retain _two_
boot "stanzas" in /etc/lilo.conf, one for your old, known-good kernel,
and one for the new-ish kernel you hope will take its place.
My laptop's /etc/lilo.conf is like this:
The point is that I am able to resort to the "linuxold" bootable image
if at any point the newer "linux" bootable image turns out to have
> Can you direct me to a reasonably readable document for compiling the
Starting at the Debian category of my knowledgebase,
http://linuxmafia.com/kb/Debian , find the entry called "Information".
That link takes you to a page of mine of primary information resources
for Debian users. It has a section called "Linux Kernels on Debian".
One or more of the items there should be useful.
> I don't know how to download the kernel from Libranet with out
> compiling it; I have to do that on one machine, copy it to a CD
> and install it in the new box, so I used the .deb kernel.
You may want to ask about that on the Libranet support forum. I'm
reasonably sure that Libranet offers some 2.6.x precompiled
kernels in .deb format, suitable for Libranet 2.8. However, there's
no reason why you shouldn't also be able to use one from
Debian-unstable, bearing in mind that it'll require you upgrading one or
two other packages, as well.
I think the modutils may be one of those? Can't remember. Hang on:
Let me check on my laptop:
Maintainer: Herbert Xu <herbert at debian.org>
Provides: kernel-image, kernel-image-2.6
Depends: initrd-tools (>= 0.1.53), coreutils | fileutils (>= 4.0), module-init-tools (>= 0.9.13)
Suggests: lilo (>= 19.1), fdutils, kernel-doc-2.6.2
There you go: Your version of the initrd-tools package (the tools for
dealing with initial RAMdisks) must be at least 0.1.53, your
module-init-tools package must be at least 0.9.13, and your guess is as
good as mine about how to parse that "coreutils or fileutils" part, but
I think it means one or the other must be present and be at version 4.0
More information about the conspire