[conspire] Re: RHL 9 Install problems

Greg Dougherty rhl at molecularsoftware.com
Tue Jul 8 16:44:48 PDT 2003

On 7/7/03, Rick Moen <rick at linuxmafia.com> writes:

> Quoting Greg Dougherty (rhl at molecularsoftware.com):
>> I tried telling it to check for Bad Blocks.  It claimed to find
>> them, and refused to install (I though formatters were supposed to
>> mark off bad blocks, not fail).
> Yes, that's what should have happened. 

Should mark them off?  Or should just fail?

> But please note that Linux installers invariably default to no
> bad-block checking, because of the amount of time it takes.

That's fine, that's why I set it to check bad blocks in Disk Druid.

> If you're in doubt about the condition of a hard drive, using the
> manufacturer's pseudo-low-level formatting utility for that model will
> sometimes make it behave properly, by re-establishing the timing tracks
> -- and the same utilities will often also do hardware diagnostics.

That would require me to HAVE said utility.  It certainly didn't come with my
drive. :-)

> Please see my list of links:
> http://linuxmafia.com/pub/hardware/hdutils

I've downloaded them.  We'll see what I can accomplish with them.

> > I downloaded the iso's from a red hat mirror, so they should be good.
> Just in case you might not have noticed, the RH installer offers, on its
> first screen, a "media check" (or words to that effect). 

Hard not to notice, it's kind of pushy about it.  :-)
One of the CD-ROM drives I tried didn't like my disks, the other did.  That's
why I tried using the RHL isos.

> > I'll try downloading the LNX-BBC iso, and see what I can do with that.
> It's handy to have, anyway -- and I like having it (as well) because
> (to me) it's a known quantity:  Whenever there's funny stuff going on
> and I want reliable diagnostic tools to reduce the number of diagnostic
> variables, its contents are useful for doing so.

I downloaded and burned it.  when I try to run fsck, it complains that the
partition is mounted.  I tried using umount (both "umount /dev/hda2" and "umount
/root", for example), and it insisted that the thing was NOT mounted.  Bad
blocks read only claimed not to find anything, and it refused to run Bad blocks
read-write, because the partition was mounted! :-(

Any suggestions?



More information about the conspire mailing list