[conspire] Re: RHL 9 Install problems

Rick Moen rick at linuxmafia.com
Mon Jul 7 14:19:16 PDT 2003

I'm Cc'ing the CABAL mailing list, "conspire".  You might consider
joining, in case further comments follow, there.

Quoting Greg Dougherty (gregd at molecularsoftware.com):

> I found you guys through the Bay Area Linux Users Group.  I'm trying to install
> Linux on my computer, and having no luck at all.  If I brought my computer and
> monitor to the Saturday 7/12 meeting, would I be able to get help?  (And, how
> late do the meetings run?  I have a class in Palo Alto until 5:30.)

Sure, that would work.  We start 4 PM, and run to about midnight.
Plenty of time.  (This meeting will also feature the Silicon Valley BSD
User Group dropping in on us, so there will be something of a party
going on in the backyard and back porch, I think.)

> My computer:
> Chieftec Dragon case (ATX tower with USB and FireWire on the front)
> ASUS A7N8X Deluxe Motherboard
> 1 Gig (2 x 512 MB) Kingston Hyper X RAM
> 1.83 GHz AMD Althlon XP "Barton" CPU
> Western Digital 40 GB Cavalier HD
> Artec 16x DVD-ROM (Supposedly Linux compatible)
> Floppy Drive, PS/2 Keyboard and mouse

Nothing stands out as problematic.

> I've had nothing but problems with RHL 9.  Large instalations fail to
> install. 


We can try my RH 9 CDs, and we can also try any of the many other
distributions I keep around.  

If you have time, try a new install and ensure that you check the
checkbox to "Check for surface defects" (or words to that effect) during
the mkfs = filesystem-creation step.  Unfortunately, that step (_with_
surface checking) can take quite a few hours with a very large
filesystem, which is why people often omit it -- with obvious
disadvantages if your hard drive hardware has a defective stretch of

You could alternatively download an LNX-BBC ISO or a Tom's Root-Boot
floppy image, to boot those media as maintenance Linux systems and run
fsck with the "-c" = check for bad blocks option:

#  fsck.ext2 -c /dev/hda1

Download sources:

Although I keep media for those and other things on hand, you may want
to create and use them yourself, in advance of Saturday, because
surface-checking a large filesystem takes such a long time.

> I finally tried installing with the 5 GB partition formatted to ext2.
> This let me do the ftp, but when I tried to install from HD, I get a
> "cpio magic" error and the install exits.

Pondering what that error could mean is what made me think it _might_ be
a hard-drive defect:  The reference to cpio is because RPMs are stored
in compressed cpio archive format (with an RPM-specific header).  "magic"
is Unix jargon for the file-type bit fingerprint in the first few dozen
bytes of any file, whereby Unix decides what type of file it is.  (The
"file" utility does this, for example.)

So, when you tried to make the RH installer unpack an RPM, and it choked
complaining about a "cpio magic" error, that means it thinks the RPM
file is corrupt and invalid.  The big question is why.  It could be that
you have a defective CD.  It could be that you have a marginal CD-reader
drive.  It could be that you have some bad blocks on your hard drive.
Or, it could be that you have some other hardware problem.

If it's bad media, we can tell by using mine.  If it's a marginal CD
reader, we can tell by swapping in one of mine.  If it's defective hard
disk blocks, your running "fsck.ext2 -c" in advance should catch and fix

If it's a different sort of hardware problem, we might have an
interesting time diagnosing it, but at least we can narrow it down.

Cheers,              First they came for the verbs, and I said nothing, for
Rick Moen            verbing weirds language.  Then, they arrival for the nouns
rick at linuxmafia.com  and I speech nothing, for I no verbs. - Peter Ellis

More information about the conspire mailing list