Subject: [TAG] Mirror 2 web servers

From: Love Sundin <[email-masked]>
Date: Thu, 18 Mar 2004 17:10:08 +0100

Hi  folks at ,The Answer Gang

I have two webservers running linux (redhat)
one of them is the primary server and the other one acts as backup

the thing is that i want to be able to mirror these servers in both ways

including this:

* mysql databases
*http folder
*httpdconfig

i was thinking a shell script would do the trick!
but my competence ends just after #!/bin/bash!

i am not asking for a complete script

just some were to turn for help :)

Mvh
Love Sundin, MacRent Hyrcentralen
Tfn: 08-673 01 00
Mob: 073-960 02 02
Fax: 08-673 01 15
[email-masked]

_______________________________________________
TAG mailing list
[email-masked]
http://linuxgazette.net/mailman/listinfo/tag

---

From: Bradley Chapman <[email-masked]>
Date: Thu, 18 Mar 2004 08:59:35 -0800 (PST)

Mr. Sundin,

> the thing is that i want to be able to mirror these servers in both ways

Well, since you're using a MySQL database, have you considered moving the MySQL
database and DBMS onto a third machine which is more powerful than the two
webservers, and simply having the webservers query the database using your
favorite RDBMS protocol. Or you could use the MySQL mirroring and load balancing
features (Google turns up a lot of links).

Many online websites, such as discussion forums, often place the DB onto a
separate machine and the Web server software onto another one (or two, or any
value of N), and use DNS round robin to rotate amongst the Web servers, thus
lessening the risk that a single machine failure will kill the site.

> just some were to turn for help :)

You can help us by supplying ASCII art defining your network topology - the
really smart people who know DBs and stuff on this list will probably need it
;-)

> Mvh

Brad

=====

__________________________________
Do you Yahoo!?
Yahoo! Mail - More reliable, more storage, less spam
http://mail.yahoo.com
_______________________________________________
TAG mailing list
[email-masked]
http://linuxgazette.net/mailman/listinfo/tag

---

From: Thomas Adam <[email-masked]>
Date: Thu, 18 Mar 2004 17:08:36 +0000 (GMT)

> Hi  folks at ,The Answer Gang

Hello.
 
> but my competence ends just after #!/bin/bash!

Have a look at the 'rsync' utility -- that will fit your needs quite
happily.

-- Thomas Adam

=====
"The Linux Weekend Mechanic" -- http://linuxgazette.net
"TAG Editor"                 -- http://linuxgazette.net

"<shrug> We'll just save up your sins, Thomas, and punish 
you for all of them at once when you get better. The 
experience will probably kill you. :)"

 -- Benjamin A. Okopnik (Linux Gazette Technical Editor)

___________________________________________________________
Yahoo! Messenger - Communicate instantly..."Ping" 
your friends today! Download Messenger Now 
http://uk.messenger.yahoo.com/download/index.html
_______________________________________________
TAG mailing list
[email-masked]
http://linuxgazette.net/mailman/listinfo/tag