[sf-lug] problems with refresh rate under Intrepid

Christian Einfeldt einfeldt at gmail.com
Tue Mar 17 18:54:55 PDT 2009


On Tue, Mar 17, 2009 at 6:17 PM, Rick Moen <rick at linuxmafia.com> wrote:

> Quoting Christian Einfeldt (einfeldt at gmail.com):
> > Okay, I have come up with a short term solution to my problem.  I have
> > clicked on
> >
> > System > Administration > Hardware drivers
> >
> > and I have activated the non-Free ATI/AMD FGLRX graphics driver.
> Suggestion:  Figure out what this _really_ did.  Post details.

Please see below.

> You've cited a "short-term solution" that has meaning only within a
> particular (and _unidentified_)

As I said, it was the non-Free ATI/AMD FGLRX graphics driver.

> software tool, that is presumably
> part of Ubuntu's GNOME suite.

More details below.

> Very likely, the tool fetched some (unidentified) package, installed
> it, then either made some edit to the configuration files in
> /etc/event.d/ or to /etc/xorg.cong (but I doubt the latter even exists
> in your distro).

Apparently, what happened is that enabling the ATI FGLRX driver allowed me
to chose from a wide range of screen resolution and refresh rates.  Before I
enabled this non-Free driver, when I ran xrandr from the console, all I
could see was this:

cje at rb:~$ xrandr
Screen 0: minimum 640 x 350, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
   1024x768        0.0*
   800x600         0.0
   720x400         0.0
   640x480         0.0
   640x350         0.0
cje at rb:~$

Right after I upgraded to Intrepid, here is what my xorg.conf file looked

Section "Monitor"
    Identifier    "Generic Monitor"
    Option        "DPMS"
    HorizSync    28-64
    VertRefresh    43-60

When I tried to change screen resolutions by clicking on System >
Preferences > Screen Resolution, all I saw was this:


In other words, I could only choose 1024 X 768 at 0 hz!

Following up on this thread, I tried pumping up the refresh rates by
changing the values as recommended here:


  Section "Monitor"
    Identifier "KVM Host Monitor"
    HorizSync 30-70
    VertRefresh 50-75
    # 'man xorg.conf' says you can set the pixel clock in KHz.
    # This is an UNTESTED example for 10-110 MHz clock:
    #Option "MinClock" "10000"
    #Option "MaxClock" "110000"
but no joy.  Still the same flicker and I am still not seeing any options
other than zero when I click on

System > Preferences > Screen resolution

However, after I enabled the non-Free ATI FGLRX driver, I was able to chose
from a wide variety of settings:
cje at rb:~$ xrandr
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 1280 x 1024
default connected 1024x768+0+0 0mm x 0mm
   1280x1024      60.0     47.0     43.0
   1024x768       75.0*    72.0     70.0     60.0     43.0
   800x600        75.0     72.0     70.0     60.0     56.0
   640x480        75.0     72.0     60.0
   640x350        70.0
   1280x960       60.0
   1280x768       60.0
   1152x864       75.0     70.0     60.0     47.0     43.0
   640x400        75.0     60.0
   512x384        75.0
   400x300        75.0     60.0
   320x240        75.0     60.0
   320x200        75.0     60.0
cje at rb:~$ gksudo gedit /etc/X11/xorg.conf

Now, my problem is solved, except that I am using a non-Free driver.  I am
hoping that problem will resolve with Jaunty.  But at least I can choose the
screen resolution that I need, whereas before I downloaded the non-Free ATI
FGLRX driver, I was not able to do so.  Before enabling the non-Free
drivers, I was using the FOSS radeohd drivers (there are two of them) which
you can find by searching your repositories for radeonhd

c u
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://linuxmafia.com/pipermail/sf-lug/attachments/20090317/a9db68b5/attachment.html>

More information about the sf-lug mailing list