[sf-lug] Nagios on CentOS (perl-Net-SNMP vs. perl-net-snmp)

Tom Haddon tom at greenleaftech.net
Fri Jun 13 12:21:37 PDT 2008

Hi Folks,

Hoping there may be a RH/CentOS guru out there who can help me figure
out what I'm missing here - I'm all at sea...

I'm trying to install nagios on a CentOS 4.6 server. I've added the
rpmforge repo per:


I'm now trying to install nagios per:


The first step (having correctly enabled the repos is:

yum [update|install] nagios nagios-plugins nagios-devel

I get the following:

Error: Missing Dependency: perl(Net::SNMP) is needed by package

I've installed net-snmp-perl (net-snmp-perl-5.1.2-11.el4_6.11.3), but
it's still complaining that it doesn't have the right package. I've
looked online and I can see that a package potentially matching the name
better is available here:


But from what I can see, I should already have access to that repo, and
I'd rather not manually install a package without knowing what I've
configured wrongly.

Any ideas?

Thanks, Tom

More information about the sf-lug mailing list