[sf-lug] hello, emulating olpc xo-1

jim stockford jim at well.com
Thu Dec 13 22:22:36 PST 2007

    i ordered a g1g1 for myself. susanna, my
g'friend, ordered two for her granddaughters,
who are 7 and 4.5. when the machines get
here, we'll be looking for someone to play.
you can bet i'll announce the machines'

On Dec 13, 2007, at 8:41 PM, Matt Price wrote:

> Hello,
> I'm new to the SF area and probably should have signed up for this list
> long ago, but was finally moved to do so by Sameer Verma when I asked a
> olpc-related question on the sugar list.  So here it is again, revised 
> a
> bit:
> My daughter is getting an xo-1 for xmas via g1g1.  I really want this 
> to
> be the best possible experience for her, so i've been experimenting 
> with
> various emulators running on my own dell d820 laptop, running a mostly
> up-to-date Ubuntu Gutsy.  In particular, I want to fool around with
> collaboration to see how that will work, and also to be sure that when
> the machine shows up, there will be someone else for Mika to 
> collaborate
> with.  It's in collaboration that I've had the most trouble and that's
> what I want to talk about.
> I've tried a bunch of different methods for pretending to be an xo-1;
> none work perfectly, but i'm hoping that someone else outthere has had
> better luck.  here's what I've seen:
> 1) use jani monoses' package archive for ubuntu,
> https://edge.launchpad.net/~jani/+archive .  This mostly works great --
> follow instructions on jani's blog, http://janimo.blogspot.com/ .  I 
> can
> pretty easily get two xo-1 instances running side-by-side; they can
> recognize each other and make friends, and also chat, but no other
> collaborative activities work -- e.g., not in paint  or write, the two
> most important i'd think.  I especially want write colaboration to 
> work,
> and jani suggested the problem might lie with the fact that the
> collaboration code is not included in the ubuntu packages of abiword.
> So I tried other methods...
> 2) use the standard downloadable qemu images from laptop.org.  Images
> downloaded fine, and after fiddling a bit to get kqemu to work I cna
> load the images pretty easily with :
> qemu -m 256 -kernel-kqemu -soundhw es1370 -net user -net \
> nic,model=rtl8139 -hda olpc-qemu-image-mika.img
> however, there's no networking, so there's no way for me to test
> collaboration.  There are various guides for getting qemu networking to
> work, but I haven't had any luck with any of them so far.  they all 
> also
> tend to extend beyond the reach of my competence.  If someone can guide
> me through that process, i'd probably be pretty happy...
> 3) use VMWare instead.  I followed the olpc wiki instructions on using
> vmware and managed to get that working as well using the mostrecent
> vmware server 1.0.4 -- sort of.  After fiddling around a bit to get
> vmware working, I downloaded the relevant vmware image, but couldn't
> make it boot into x -- several xorg modules were missing, among them 
> dri
> and glx, i believe.  Anyway, figured that might be an issue with the
> particular image version, so I tried converting the functional qemu
> image to vmdk using
> qemu-img convert my-image.img -O vmdk my-image.vmdk
> but attempts to add this image to my virtual machine merely caused
> vmware to crash.  so again, i wasn't able to test the collaboration
> facilities.
> So all this leaves me a little discouraged, and i'm hoping for a little
> guidance from the community.  Is there anyone out there who has a 
> really
> solidly-working xo-1 emulation working on a ubuntu system?  if so, 
> would
> you be willing to share your secrets with me?
> Anyway, thanks a lot, look forward to more contact sometime,
> Matt
> -- 
> Matt Price
> matt.price at utoronto.ca
> _______________________________________________
> sf-lug mailing list
> sf-lug at linuxmafia.com
> http://linuxmafia.com/mailman/listinfo/sf-lug

More information about the sf-lug mailing list