[conspire] Linux on imac G3

Rick Moen rick at linuxmafia.com
Thu Oct 25 10:46:36 PDT 2007

Quoting John Andrews (jla1200 at netzero.net):

> Should I update the firmware on the old iMac before I install Ubuntu?

I'm not aware of any compelling reason.  Daniel might know more.

http://docs.info.apple.com/article.html?artnum=75130 has what appears to
be the latest firmware update for G3 iMacs ("iMac Firmware Update 4.1.9").  
Note README, which includes system requirements and other advice:  "The
iMac Firmware Update 4.1.9 will only run on iMac computers with
slot-loading CD or DVD drives running Mac OS 9.1 or later from a local
drive. [...]  Firmware Update 4.1.9 includes improvements to starting up
Mac OS X from the local hard disk, Firewire target disk mode, starting
up from the local hard disk, network startup, and system stability. This
update also adds support for additional security options which allow the
Open Firmware to be password protected." You'll want to read the rest,
about auto-wiping of the parameter RAM (PRAM), how to run the updater,
and where/when to frob the "programmer's button" after rewriting the

> I'm erasing the old 9.0 but I know the firmware is out of date. Isn't  
> that in a chip somewhere?


> Would it effect the new Ubuntu?

I'm guessing "No."

More information about the conspire mailing list