[conspire] continuing problems with getting an IP address for eth0 - any suggestions as to the cause and/or cure

Daniel Gimpelevich daniel at gimpelevich.san-francisco.ca.us
Mon Jun 5 09:29:09 PDT 2006

How consistently do you get an IP address when bringing up eth0 while
connected directly to the modem without the hub? As was mentioned earlier,
the duplex setting within the NIC may not be getting negotiated to "half"
properly. Since this is a function of the NIC and its driver, the problem
can be misattributed to a faulty NIC. Unfortunately, the proper duplex
setting for a computer connected directly to the modem is also "half," so
really the only other configuration you could test that would make a
difference would be to borrow a switch to put in place of the hub.
However, unmanaged switches are usually known to cause this type of
problem rather than solve it, but it's something you haven't tried yet.

The command equivalent to the Activate button is "sudo ifup eth0" and the
Deactivate button is "sudo ifdown eth0" which both give feedback from
which you can instantly tell whether or not it worked, without bothering
with ifconfig.

Sometimes, for no apparent reason, dhclient will successfully get an IP
address but fail to write the /etc/resolv.conf file, leaving you unable to
surf the web. When this happens, you can do either of two things:
Temporarily overwrite the file yourself, or bring eth0 down and back up.
The latter assumes you can consistently get an IP address.

On Mon, 05 Jun 2006 09:30:01 -0700, Darlene Wallach wrote:

> I'm having continued problems getting an IP address. This is a new
> problem as of the end of May/beginning of June.
> Either I'm finally getting an IP address or by disconnecting
> both the hub and modem and connecting the modem, waiting for
> the ready light on the modem to be steady then connecting the
> hub sometimes successfully gets me an IP address.
> Here is the output of /sbin/ifconfig
> eth0      Link encap:Ethernet  HWaddr 00:D0:B7:79:FF:A2
>            inet addr:  Bcast:  Mask:
>            inet6 addr: fe80::2d0:b7ff:fe79:ffa2/64 Scope:Link
>            UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>            RX packets:9201 errors:5 dropped:0 overruns:0 frame:5
>            TX packets:7042 errors:0 dropped:0 overruns:0 carrier:0
>            collisions:26 txqueuelen:1000
>            RX bytes:10226811 (9.7 MiB)  TX bytes:671935 (656.1 KiB)
> lo        Link encap:Local Loopback
>            inet addr:  Mask:
>            inet6 addr: ::1/128 Scope:Host
>            UP LOOPBACK RUNNING  MTU:16436  Metric:1
>            RX packets:48 errors:0 dropped:0 overruns:0 frame:0
>            TX packets:48 errors:0 dropped:0 overruns:0 carrier:0
>            collisions:0 txqueuelen:0
>            RX bytes:6759 (6.6 KiB)  TX bytes:6759 (6.6 KiB)
> When I spoke with tech support the other evening, the person I spoke
> with suggested my nic was bad and should be replaced. Since then I
> have connected multiple times.
> Any suggestions as to what the problem might be and/or what I can do
> to consistently get an IP address?
> Darlene

More information about the conspire mailing list