[conspire] K3B/KDE

Rick Moen rick at linuxmafia.com
Mon Sep 8 17:04:42 PDT 2003

Just catching up on old threads.  That's the nice thing about using the
NNTP/newsreader side of this mailing list / newsgroup setup:  You can
respond to any past message, even the ones you've long ago deleted from
your mailbox.

Bill Stoye <skiffworks at earthlink.net> wrote:

> Running Red Hat 9 and using Gnome as the window manager, I tried to
> install the "K3B" CD burner software; it requires KDE, installed that
> from the RH9 Installation CD; using Synaptic I attempted to install K3B.
> Clicking on the .rpm would not open and install the program, through
> someones advise I was able to install it with the command line; then
> running "k3b setup", it gets to step 5 of 6 and freezes the machine,
> each and every trime; get out of that with "Ctrl,Alt,Backspace".
> When installing KDE, I mistakingly selected "Servers" and installed
> them; not really wanting servers, I tried to use "Add?Remove
> Applications" to remove them and I get this Error message:
> "The following packages could not be found on your system.  Installation
> cannot continue until they are installed:
> "redhat-config-security level" required by "first boot"
> "redhat-config-printer-gui"      required by "desktop-printing"
> Went to Synaptic again, it tells me they are already installed, did an
> 'UpGrade All";  no change in behavior.
> I would like to have a running K3B and remove the servers.

Wow, it sounds as if the package-management system has somehow become
deeply confused.  One thing that might help (and cannot hurt) is to
rebuild the RPM package database.  _Close_ all package-management
programs, then open a root-user shell, and do:

# rpm -v --rebuilddb | more 

(The -v is the "verbose" switch.  I just prefer to see details.)

I assume you were trying to use Synaptic as a package-management
front-end to remove the KDE "Servers" packages (whatever those are).  
In the above, you don't say clearly what software tool you used; you say
only you used "Add/Remove Applications" (which leaves us hanging a bit,
but I'm _guessing_ you're referring to a screen within Synaptic).

Ordinarily, I would expect Synaptic (if that's what you used) to be able
to deal intelligently with your already-installed packages, contrary to
the rather wacky output you quote at the end.  If rebuilding the RPM
database doesn't do the trick, then it's probably best to switch to a
lower-level tool, the /usr/bin/rpm command-line package tool, in order
to de-complicate your diagnostic situation.

# rpm -qa | more

...will list the names and versions of all installed packages.  

# rpm -e packagename

...will remove packagename.  (Specify _just_ the name, not name+version.)
You can/should put the list of all the aforementioned "Servers" package
names on one such command line, and let 'er rip.

That, with reasonable luck, will fix your second problem (that of
undesired packages, and a misbehaving package front-end program).  As to
the original problem (installing K3B), you don't really give us a lot to
go on:

> I was able to install it with the command line;

What does this mean?  What command line?  Would you mind saying
specifically what you mean?

> ...then running "k3b setup", it gets to step 5 of 6 and freezes the machine

One problem is that probably nobody here has any idea what "step 5" is.
If you'd like us to help you, you'll have to be a lot more specific.
No offence intended; that's just the way it is.

Cheers,              Wall Street has all the emotional stability of a 
Rick Moen            thirteen-year-old girl.   -- Louis Rukeyser
rick at linuxmafia.com

More information about the conspire mailing list